NetTalk Central

Author Topic: Forms behave strangely in version 14.17  (Read 718 times)

Niels Larsen

  • Sr. Member
  • ****
  • Posts: 419
    • View Profile
    • Email
Forms behave strangely in version 14.17
« on: February 09, 2024, 11:17:36 AM »
Hi Bruce

I just installed version 14.17.
But something is wrong. If I take the example "BasicBrowseAndForm (1)" - press insert in the browser - the form appears but immediately disappears again.
I experience something similar in my own apps. Here, I may be allowed to type in the first field, but when I move on to the next field, the form closes.
Am I the only one experiencing this?

Regards Niels

Vinnie

  • Full Member
  • ***
  • Posts: 175
    • View Profile
    • Email
Re: Forms behave strangely in version 14.17
« Reply #1 on: February 09, 2024, 11:24:24 AM »
I also have an Issue with NetTalk 14.17.

Mine is with Forms also where fields have moved.

Maybe Span Prompt Value Comment or

refactoring Form Cell Start / End Code

Switched back to NetTalk14.16

osquiabro

  • Hero Member
  • *****
  • Posts: 666
    • View Profile
    • Email
Re: Forms behave strangely in version 14.17
« Reply #2 on: February 09, 2024, 12:20:46 PM »
humm i have another issue in form, when press tab automatic fired a requiered for the next field and when press cancel and yes the form not closed, go back to 14.16

Bruce

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 11171
    • View Profile
Re: Forms behave strangely in version 14.17
« Reply #3 on: February 11, 2024, 10:32:32 PM »
Thanks to Niels posting an example (or noting which shipping example that shows the effect_ the open/close issue is fixed for 14.18.
I suspect Osa's report is based on the same root problem, and is also fixed.

I don't have an example of your issue yet Vinnie, so unfortunately no way to debug that yet.

Cheers
Bruce

Vinnie

  • Full Member
  • ***
  • Posts: 175
    • View Profile
    • Email
Re: Forms behave strangely in version 14.17
« Reply #4 on: February 12, 2024, 02:25:48 AM »
Thanks Bruce. Not a problem.

I will do more investigation later this week. NetTalk14.16 is great for the time being.

I will start a new thread if required.