NetTalk Central

Author Topic: Subject Problem  (Read 16152 times)

Alberto

  • Hero Member
  • *****
  • Posts: 1845
    • MSN Messenger - alberto-michelis@hotmail.com
    • View Profile
    • ARMi software solutions
    • Email
Subject Problem
« on: May 08, 2009, 02:50:19 AM »
Hi,
I´m sendig mails from my site the way the example like:

loc:result = SendEmail('server smtp',25,'from',USU:EMAIL,p_web.Translate('Global Medic Registration'),'','','',......

All is ok but... when I translate to spanish the word _Registración_ appears in the arrived email as _Registracisn_ changing the ó by an s.

This happens only in the _Subject_, the same translation looks ok in the HTML body.

How can I solve it?
Thanks
Alberto
-----------
Regards
Alberto

Robert Iliuta

  • Sr. Member
  • ****
  • Posts: 469
    • View Profile
    • Email
Re: Subject Problem
« Reply #1 on: May 08, 2009, 04:11:04 AM »
Hallo Alberto,


Did you set the default non-unicode language to Spanish ? I solve this
problem after I set the default language for non-unicode to Romanian.

Control Panel > Regional and Language Options > Advanced > here select the
language.

In my case solved the problem.  I don't think it's a problem from NT.


Regards,
Robert Iliuta

Alberto

  • Hero Member
  • *****
  • Posts: 1845
    • MSN Messenger - alberto-michelis@hotmail.com
    • View Profile
    • ARMi software solutions
    • Email
Re: Subject Problem
« Reply #2 on: May 08, 2009, 04:32:20 AM »
Mhhh, may be, the problem is this is used in a web server, there are users
of many languages, the Subject is translated in runtime.
I cant change the server regional language each time an email is sent.
Thanks
-----------
Regards
Alberto

Bruce

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 11171
    • View Profile
Re: Subject Problem
« Reply #3 on: May 11, 2009, 09:46:19 PM »
Sean Says:

NetTalk allows you to specify the encoding that you are using to send mails
in. The default is 'us-ascii', but you can also use 'iso-8859-1' or 'utf-8'.
You can set both the character set and the text encoding used. For example
you can use 'utf-8' as the character set and 'quoted-printable' as the text
encoding to allow any character sets to be sent, and just setting the
character set to 'iso-8859-1' may work in your case.

Roberto Says:
in you sendemail window inside the -Control Events/?EmailSend/Accepted
    embed after generated code, just add the following line

ThisSendEmail.OptionsMimeTextCharset =  'iso-8859-1'

That should let you work in any characterset



seancameron

  • Newbie
  • *
  • Posts: 16
    • View Profile
    • CapeSoft Software
Re: Subject Problem
« Reply #4 on: May 23, 2011, 12:45:46 AM »
This doesn't apply to the Subject line, which doesn't support character sets outside of ASCII. There is a workaround in later versions of the SMTP specification for this that provides multiple encodings within the Subject, however it is not currently supported by NetTalk.
Sean Cameron
CapeSoft
www.capesoft.com

Work Smarter, Not Harder

Alberto

  • Hero Member
  • *****
  • Posts: 1845
    • MSN Messenger - alberto-michelis@hotmail.com
    • View Profile
    • ARMi software solutions
    • Email
Re: Subject Problem
« Reply #5 on: May 23, 2011, 02:24:14 AM »
I´m having a problem with the subject line.
I´m sending the same mail to a hotmail account and my own account:
alberto-michelis@hotmal.com ; info@armi.com.ar

In the subject line of the received email of the hotmail account I get the right character
Registración

In the subject line of the received email of the armi.com.ar account I get no character
Registracin

Any way to fix this?
Thanks
-----------
Regards
Alberto

Bruce

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 11171
    • View Profile
Re: Subject Problem
« Reply #6 on: May 23, 2011, 03:06:28 AM »
sounds like an issue with the received, not the sender...

cheers
Bruce