NetTalk Central

Author Topic: Export not correct  (Read 316 times)

mmelby

  • Newbie
  • *
  • Posts: 33
    • View Profile
    • Email
Export not correct
« on: April 15, 2022, 04:58:46 AM »
I have a small system. One windows based program and one web based program. They access the same 2 files on the same Windows server. They both have a function to export a file to csv. The problem is with the web based export. If I delete a record and run the export the deleted record is still in the web based export. It is not in the Windows based export and the record is not found in a browse in either program. If I restart the web based program the record goes away. Note, the web based program runs as a service.

It appears that there is something not being cleared but I have no idea what that could be.

I have attached a text file that contains the code that I use to create the export file.

I would be happy to provide the complete programs if that will help.

Regards,
   Mike
« Last Edit: April 15, 2022, 05:33:41 AM by mmelby »

Jane

  • Sr. Member
  • ****
  • Posts: 261
  • Expert on nothing with opinions on everything.
    • View Profile
    • Email
Re: Export not correct
« Reply #1 on: April 15, 2022, 07:38:40 AM »
Just taking a WAG here, Mike.  I'd try clearing the "Enable File Cache" checkbox on the web server extension Performance tab.

Bruce

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10772
    • View Profile
Re: Export not correct
« Reply #2 on: April 15, 2022, 09:45:43 PM »
yes, if the file is small, and you are generating, then regenerating it, it might be served from the internal server cache. Try turning that off if you are going this route.

Cheers
Bruce

osquiabro

  • Hero Member
  • *****
  • Posts: 577
    • View Profile
    • Email
Re: Export not correct
« Reply #3 on: April 16, 2022, 04:05:23 AM »
Hi Bruce, would that affect a performance of site

Bruce

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10772
    • View Profile
Re: Export not correct
« Reply #4 on: April 18, 2022, 02:00:02 AM »
probably not that you'd notice, assuming you have the site in "performance" mode, which I'm guessing you do if you have the cache on.

mmelby

  • Newbie
  • *
  • Posts: 33
    • View Profile
    • Email
Re: Export not correct
« Reply #5 on: April 18, 2022, 07:55:42 AM »
Thank you! Turning off file caching has resolved my issue. I have not noticed a performance issue with this setting but it is a very small app.