NetTalk Central

Author Topic: Error 530 Sending Email  (Read 6052 times)

bryce

  • Newbie
  • *
  • Posts: 24
    • View Profile
    • Email
Error 530 Sending Email
« on: October 18, 2013, 10:28:35 PM »
I have a program which sends emails and it works perfectly when I am connected to the Internet through my normal router on the desktop.

However, as soon as I connect using a 'Mobile Wifi router' I get the following error when attempting to send an email:

NetTalk Object Error

A network communication error has occurred.

Error = Error n this message.  The remote Email (SMTP) server sent error = 530 Authentication required State = 74 Will try and send next email.

Error occurred in function: NetEmailSendProcess

The connection to the Internet via a browser works fine but the email sending doesn't.

Can anyone give me any ideas what this might be?  I am a bit perplexed as nothing changes except the router.

Thanks.

Bryce

bshields

  • Sr. Member
  • ****
  • Posts: 392
    • View Profile
    • Inhabit
    • Email
Re: Error 530 Sending Email
« Reply #1 on: October 19, 2013, 02:17:59 PM »
Hi Bryce,

If your mobile Wifi Router connects to an ISP, rather than your own infrastructure, you might find it is a security measure used by the ISP. Many "domestic" ISPs will block all SMTP access except for their own STMP Server. This limits the damage a Mailware/Virus Bot can do.

If so, just change your STMP to that recommended by the ISP (and you can probably turn off authentication) and it should work.

Regards
Bill

bryce

  • Newbie
  • *
  • Posts: 24
    • View Profile
    • Email
Re: Error 530 Sending Email
« Reply #2 on: October 19, 2013, 08:48:46 PM »
Bill,

Thank you for that information.  I was totally at a loss.  I shall do what you suggest and then hopefully be up and running whilst mobile.

Bryce