NetTalk Central

Author Topic: Multi Site Host NT 14.11  (Read 1152 times)

aren1968

  • Newbie
  • *
  • Posts: 3
    • View Profile
    • Email
Multi Site Host NT 14.11
« on: November 02, 2023, 12:14:54 PM »
I have a problem with host not using the location for web and data folder set up in the web interface.
I set the web folder to C:\Shared\Prosjekter\Gallot\GaMobile\web and data folder to C:\Shared\Prosjekter\Gallot\GaMobile
When I upload a picture it goes to C:\Shared\MultiSite\web\uploads
However my program expects it to be in C:\Shared\Prosjekter\Gallot\GaMobile\web
Am I doing something wrong here?

Bruce

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 11220
    • View Profile
Re: Multi Site Host NT 14.11
« Reply #1 on: November 02, 2023, 09:00:21 PM »
I'm confused by your report.
You mention the _web_ and _data_ folders not being applied correctly (but no evidence to that effect) and then evidence for the _uploads_ folder not being correct.

Can you clarify please?
a) if you put a file in the \web folder can you fetch it?
b) is the data folder setting correctly finding the TPS files (or whatever) that you expect?
c) Is the problem _only_ with uploads?

Cheers
Bruce

aren1968

  • Newbie
  • *
  • Posts: 3
    • View Profile
    • Email
Re: Multi Site Host NT 14.11
« Reply #2 on: November 03, 2023, 12:31:57 AM »
The 'client' application is based on mssql with fm3 applied.
If I upload an image, it is saved to host web\uploads folder.
If I copy the file I uploaded to 'client' web\uploads folder, then it is retrieved, and shows.
If I put the image in a blob, it shows.

An uploaded image saves to the record as '\uploads\tireg.jpg'  (for this field the 'Remove webfolder path from incoming file name' is on)
It is upladed to the host web\upload folder.
In the dll app, it does not show, until I copy it to the web\uploads\ folder of the 'client'

So, I made a new field, where 'Remove webfolder path from incoming file name' is ticed off.
The uploaded image saves to: 'C:\Shared\MultiSite\web\uploads\timeknapper.jpg'

If this is what it should be like, how do I save uploaded files to the 'client' web\uploads folder? 
I also tried to add a disconnected web app to the host.
It works standalone, but as a dll the syncronization fails.
The reply from debugview is no file found in host folder, for each file to sync.
The paths for web and data folders are set up correct.

Regards
Are