NetTalk Central

Author Topic: email send control template error 12.55  (Read 1707 times)

Richard I

  • Sr. Member
  • ****
  • Posts: 385
    • View Profile
    • Email
email send control template error 12.55
« on: February 16, 2023, 03:19:03 PM »
HI
I have  2 compile errors in the emailsendcontrol template following the upgrade to NT 12.55
errors are Unknown identifier:PEMAIL
               Field not found: PTOKEN
 ThisSendEmail.token = pEmail.pToken

What is this and how do I rectify please?
Thanks
Regards,
Richard

osquiabro

  • Hero Member
  • *****
  • Posts: 678
    • View Profile
    • Email
Re: email send control template error 12.55
« Reply #1 on: February 16, 2023, 03:52:55 PM »
go to any window that have net send email template, setting in Oauth Token delete pEmail.pToken and compile again

same problem.

Richard I

  • Sr. Member
  • ****
  • Posts: 385
    • View Profile
    • Email
Re: email send control template error 12.55
« Reply #2 on: February 16, 2023, 05:55:50 PM »
Thanks...
By deleting the line, doesnt stop the email send?
Cheers
Richard

Bruce

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 11204
    • View Profile
Re: email send control template error 12.55
« Reply #3 on: February 16, 2023, 07:49:33 PM »
deleting that line does not stop the email send.

Bruce

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 11204
    • View Profile
Re: email send control template error 12.55
« Reply #4 on: February 16, 2023, 07:54:32 PM »
so let's be specific;

There's a new template option on the SendEmailControls template.
It's _defaulting_ to a value which is correct for the "SendEmail" Procedure.
but if you have the SendEmail object in other procedures, it should be blank.

I will investigate removing the default, but for now I want it there because it's an important setting for the SendEmail procedure.