NetTalk Central

Author Topic: Error when updating NT12.19 to NT12.41  (Read 191 times)

jking

  • Sr. Member
  • ****
  • Posts: 322
    • View Profile
    • Email
Error when updating NT12.19 to NT12.41
« on: May 14, 2022, 04:20:29 PM »
Hello Bruce,

     I updated a NT 12.19 app to NT 12.41.  I get a single error as seen in the attached image:

          Unknown identifier: DATAMENU:ISINVALID

     The DataMenu procedure is a NetWebForm displayed/called on another NetWebForm.

      I scanned the latest docs and NetTalk Central but have not found anything.  Can you help?

Thanks,

Jeff King
« Last Edit: May 14, 2022, 04:27:49 PM by jking »

jking

  • Sr. Member
  • ****
  • Posts: 322
    • View Profile
    • Email
Re: Error when updating NT12.19 to NT12.41
« Reply #1 on: May 15, 2022, 10:20:38 AM »
Bruce,

     I solved the issue, I think.  When calling this NetWebForm, I had the procedure name set to DataMenu but the Equate was set to procDataMenu.  See the attached image.  This worked in NT 12.19 but gave the error in NT 12.41.  I set both the procedure and equate to DataMenu and the error went away.  Perhaps NT 12.41 handles the procedure and equate fields differently?

Thanks,

Jeff

Jane

  • Full Member
  • ***
  • Posts: 249
  • Expert on nothing with opinions on everything.
    • View Profile
    • Email
Re: Error when updating NT12.19 to NT12.41
« Reply #2 on: May 15, 2022, 12:46:47 PM »

Bruce

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10733
    • View Profile
Re: Error when updating NT12.19 to NT12.41
« Reply #3 on: May 15, 2022, 10:51:51 PM »
no, not you Jane, but fixed for 12.42

jking

  • Sr. Member
  • ****
  • Posts: 322
    • View Profile
    • Email
Re: Error when updating NT12.19 to NT12.41
« Reply #4 on: May 16, 2022, 05:52:02 PM »
Thanks Bruce!