NetTalk Central

Author Topic: NetTalk 12 and threads  (Read 198 times)

rainerwallenius

  • Jr. Member
  • **
  • Posts: 70
    • View Profile
    • Email
NetTalk 12 and threads
« on: December 15, 2021, 10:33:42 PM »
Hi all!

To serve many users at the same time, I set global filenames in Webhandler processlink. If I use THREAD files and filenames this does not seem to work anymore in NT12. Any idea What have I missed?

Thanks again
:: rainer

Vinnie

  • Full Member
  • ***
  • Posts: 156
    • View Profile
    • Email
Re: NetTalk 12 and threads
« Reply #1 on: December 16, 2021, 12:03:16 AM »
Hi.

May not be your answer but
Yes this still works with NetTalk 12.29

I did get have one issue a few updates ago (12.2???) when the processlink Priority moved in the Webhandler

Please check the your code priority - Mine set to 4999

Works perfect for me.

Cheers

Vinnie


rainerwallenius

  • Jr. Member
  • **
  • Posts: 70
    • View Profile
    • Email
Re: NetTalk 12 and threads
« Reply #2 on: December 16, 2021, 12:48:04 AM »
Hi Vinnie

Thanks, that worked like a charm!
From priority 5001 to 4999

:: rainer

michelis

  • Hero Member
  • *****
  • Posts: 1754
    • MSN Messenger - alberto-michelis@hotmail.com
    • View Profile
    • ARMi software solutions
    • Email
Re: NetTalk 12 and threads
« Reply #3 on: December 16, 2021, 04:28:55 AM »
Hi all, its always better to code in the embeditor, that way you see where are you adding code and dont need to think in priority.
Hope this helps.
Regards
-----------
Regards
Alberto

Bruce

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10636
    • View Profile
Re: NetTalk 12 and threads
« Reply #4 on: December 16, 2021, 08:42:15 PM »
>> Hi all, its always better to code in the embeditor, that way you see where are you adding code and dont need to think in priority.

This a thousand times. Editing code via the embed tree is evil. Don't do it.

cheers
Bruce

Vinnie

  • Full Member
  • ***
  • Posts: 156
    • View Profile
    • Email
Re: NetTalk 12 and threads
« Reply #5 on: December 17, 2021, 12:07:01 AM »
Thanks for the replies.

I think you have msiunderstood the issue.

The issue was not how the Processlink code was added via the embeditor or not.

The issue was that apps that have worked for many years may be effected after NetTalk update 12.26
Fix: Priority of ParentCall generation of WebHandler Authenticate method.

This had a side effect which in very low number of cases effected to code in processlink.

I used Priority to explain where the issue was and how to fix. I am not suggesting that is how to code.

I only mention this in case it catches someone who maybe updating from older version.

Cheers

Vinnie