Home Forum Download/Upload Links Search

NetTalk User Group

NetTalk User Group Meeting!
Live Webinar!
Saturday Nov. 16 
7am PST
Click Here To Register!
Home arrow Forum arrow NetTalk E-Mailarrow E-Mail - Ask For Helparrow NetTalk 6.29 IMAP client example Receive.app
NetTalk Central
April 19, 2014, 07:10:32 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Welcome to the NetTalk Central Forums!
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: NetTalk 6.29 IMAP client example Receive.app  (Read 654 times)
mtabakin
Newbie
*
Posts: 39


View Profile Email
« on: May 15, 2012, 10:27:30 AM »

I need to implement an IMAP client so I compiled the NetTalk 6.29 IMAP client example "Receive.app". When I run it I do connect to the IMAP host and get the number of messages in the various folders but get the following errors and can not retrieve or see any of the messages:

From NetTalk........

A network communication error occurred
Error = Error - 102 The response was invalid or incomplete [Too few Response entries]
Error occurred in function NetImap.DoneStatus

This is followed by...........

A network communication error occurred
Error = Error - 102 The response was invalid or incomplete [Undetermined section]
Error occurred in function NetImap.SplitResponse

Followed by.............

A network communication error occurred
Error = Error - 112 Invalid or malformed STATUS response. [Not a STATUS response]
Error occurred in function NetImap.ParseStatus

The NetTalk example "Response" window shows the following:

Command: STATUS
* Bad expected 1*<any ASTRING_CHAR expect '+'>
instead of "\"
a001 BAD expected closing DQUOTE

If I setup the IMAP connection in Microsoft Outlook Express I get the folders and all the messages.

I'm using C6.3 with NetTalk 6.29. Anyone know what these errors mean and what I need to do to get the NetTalk IMAP client example to work?
Logged
Bruce
Global Moderator
Hero Member
*****
Posts: 6367



View Profile
« Reply #1 on: May 15, 2012, 10:12:39 PM »

Mike - there can be variety in the way servers work (despite the "standards"). It would seem that your server is doing something here unexpected by the client, either because the client is deficient, or because the server is different.

Can you send me the connection details to the server, so I can access it from here? The easiest way to be sure about the answer is to duplicate the effect here.

cheers
Bruce
Logged
mtabakin
Newbie
*
Posts: 39


View Profile Email
« Reply #2 on: May 16, 2012, 11:57:13 AM »

Bruce,

Because this deals with an active client I don't want to post the reply here. I'll send it to you separately. Thanks.

Logged
Bruce
Global Moderator
Hero Member
*****
Posts: 6367



View Profile
« Reply #3 on: May 18, 2012, 03:51:29 AM »

thanks Mike - problem is fixed in 6.31

cheers
Bruce
Logged
mtabakin
Newbie
*
Posts: 39


View Profile Email
« Reply #4 on: May 21, 2012, 11:03:06 AM »

Hi Bruce,

Upgraded to NT 6.31 (C63) and recompiled the CS IMAP example receive.app. Still getting errors although different than before. Also tried the C8 example and it gives the same errors. Ran receive.exe with the /netall debugging parameter and have attached the log file. The connection information for the client is the same as I sent you in a private email. Hope this helps tracking down the IMAP problem. Thanks.

Mike
Logged
Bruce
Global Moderator
Hero Member
*****
Posts: 6367



View Profile
« Reply #5 on: May 22, 2012, 06:08:00 AM »

Hi Mike,

I've re-tested here against your server and it seems ok. At least for the connect and initial list of unread emails.

Can you send me a screen-shot of the error you are getting (I think via email would be best) also, a Cut & Paste of the data on the "Conversation" tab of the example.

also - I'm just doing a connect - if you are doing more, then getting the error then let me know.

cheers
Bruce
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC
Joomla Bridge by JoomlaHacks.com
Valid XHTML 1.0! Valid CSS!

Login Form

Welcome Guest.






Lost Password?
No account yet? Register
home contact search contact search