NetTalk Central

Author Topic: File Upload Problems 11.22  (Read 196 times)

astahl

  • Sr. Member
  • ****
  • Posts: 284
    • View Profile
    • Email
File Upload Problems 11.22
« on: September 23, 2019, 03:22:47 AM »
Hi All,

Has anyone had problems uploading files to a WebServer? Installed NT11.22 from NT11.21 file upload no longer works.

I see in the history notes that a change was made to, "Fix: File Upload fields did not set %FormField correctly.".
It does not upload the selected file to the uploads folder, but says it successfully uploaded the file.

UPDATE: I tested the file upload app in NT/WebServer/Examples and that also failed to upload a file to the uploads folder.


Ashley
« Last Edit: September 23, 2019, 04:02:45 AM by astahl »

Mike McLoughlin

  • Full Member
  • ***
  • Posts: 110
    • View Profile
    • Clarion Templates
    • Email
Re: File Upload Problems 11.22
« Reply #1 on: September 23, 2019, 09:55:02 AM »
I'm getting a compile problem for my Uploads procedure in 11.22 - it's looking for "Loc:filename"
Mike McLoughlin

astahl

  • Sr. Member
  • ****
  • Posts: 284
    • View Profile
    • Email
Re: File Upload Problems 11.22
« Reply #2 on: September 24, 2019, 02:53:26 AM »
Mike,

If you have "Remove WebFolderPath from incoming file name" unchecked then it is looking for Loc:filename. Check-it and the error goes away.

Ashley

Bruce

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9848
    • View Profile
Re: File Upload Problems 11.22
« Reply #3 on: October 09, 2019, 02:32:53 AM »
fixed for 11.23

astahl

  • Sr. Member
  • ****
  • Posts: 284
    • View Profile
    • Email
Re: File Upload Problems 11.22
« Reply #4 on: October 09, 2019, 07:33:56 AM »
Thanks Bruce


Ashley

astahl

  • Sr. Member
  • ****
  • Posts: 284
    • View Profile
    • Email
Re: File Upload Problems 11.22 and 23
« Reply #5 on: October 12, 2019, 02:41:29 AM »
Hi Bruce,

File upload still does not work in 11.23 using FileUpload(26) app.

Ashley

peterH

  • Sr. Member
  • ****
  • Posts: 380
    • View Profile
Re: File Upload Problems 11.22
« Reply #6 on: October 13, 2019, 10:57:52 PM »
Now it's the opposite of what astahl reported earlier. If "Remove WebFolderPath from incoming File name" is checked then the file is uploaded but not found when trying to copy to a blob field. Uncheck, and it works.

And this is 11.23

Peter

osquiabro

  • Sr. Member
  • ****
  • Posts: 372
    • View Profile
    • Email
Re: File Upload Problems 11.22
« Reply #7 on: Today at 04:12:54 AM »
hi peterH, i have a same problem with blob field.